ISL Online - Phishing emails being sent - 2023-11-06
Incident Report for ISL Online
Resolved
This incident has been resolved.
Posted Jan 08, 2024 - 13:48 CET
Identified
Phishing emails are being sent that are using ISL Online's name.
The emails are formatted to look like they are sent from ISL Online and contain a link to a 3rd party website.

We strongly recommend our users to exercise caution and avoid clicking any links in these and other similar emails. You can check if the email is sent by a legitimate ISL Online source by confirming that the sender's email domain is "@islonline.com".

If you are unsure whether an email you received is legitimate, we kindly ask you to forward the email to support@islonline.com and our team will gladly assist you further.
Posted Nov 06, 2023 - 15:45 CET
This incident affected: ISL Online Cloud (Africa, Asia, Australia, Europe, North America, South America) and Help Pages, Online Shop, Partners Portal, REST API, Web Pages.