We have implemented a solution to the issue affecting some ISL Online Cloud users with the Ctrl+Alt+Del shortcut not working during remote sessions.
A fix is included in ISL AlwaysOn, ISL Light, and ISL Light Client version 5.0.2551.156 for Desktop, now available for hosted service users in all countries except Japan. We recommend updating to this version as soon as possible: https://help.islonline.com/20067/502551147
Our team is continuing to closely monitor the situation. We apologize for any inconvenience this may have caused and will continue to provide updates on the situation.
Posted Aug 28, 2026 - 15:22 CEST
Identified
We have identified the root cause of the issue affecting some ISL Online Cloud users with the Ctrl+Alt+Del shortcut not working during remote sessions. This is caused by a recent update to how our ISL applications interact with the Windows Secure Attention Sequence (SAS) API. The interaction stops working when SAS is enabled, but the application allowed to generate SAS is set to None in the system policy. This issue only affects the latest version, 5.0.2551.150 (https://help.islonline.com/20067/502551147).
As a workaround, affected users can either use the previous version of the ISL applications, or enable SAS generation on the remote computer by setting the policy to either "Ease of Access applications" or "Services and Ease of Access applications".
Our team is working to develop and implement a solution as quickly as possible.
We apologize for any inconvenience this may cause and will continue to provide updates on our progress.
Posted Aug 28, 2026 - 11:14 CEST
This incident affects: ISL Online Cloud (Africa, Asia, Australia, Europe, North America, South America).