ISL Online Support Email Disruption - 2026-03-09

Incident Report for ISL Online

Resolved

This incident has been resolved.
Posted Mar 09, 2026 - 13:46 CET

Monitoring

We have identified the root cause of the issue preventing support emails from being received and have applied a fix.

We will continue to monitor the situation to ensure everything remains stable.
Posted Mar 09, 2026 - 11:59 CET

Investigating

We are currently investigating an issue where support emails sent to ISL Online are not being received. As a result, we are temporarily unable to offer support via email until this issue is resolved. Our team is actively looking into the root cause.

In the meantime, we encourage customers who require assistance to reach out via our live chat: https://www.islonline.com
Posted Mar 09, 2026 - 11:26 CET
This incident affected: Help Pages.